Skip to content
logo Knowledgebase

Campañas de reclamación - Error "Problema de conversión de divisa"

Created on  | Last modified on 

Summary

Error "Problema de conversión de divisa" en una Campaña de reclamación.

Description

Al crear y validar una Campaña de reclamación, se produce el error "Problema de conversión de divisa", lo que impide su ejecución y, en consecuencia, evita el envío de los correos de reclamación a los clientes.

Cause

En una Campaña de reclamación, puede ocurrir que se incluyan Vencimientos en una Divisa distinta a la de la Sociedad. Por ejemplo, un cliente puede tener un Vencimiento pendiente en USD mientras que la Divisa de la Sociedad es EUR. En este caso, el sistema utiliza dos valores parámetros: CURSHRFLD (Divisa en campos comunes) y TYPCURSHR (Tipo de cambio en campos comunes). Ambos deben estar correctamente informados para que la Campaña de reclamación pueda crearse y validarse correctamente.

Este error tambien puede ocurrir si la Campaña de reclamación se ejecuta a través de una tarea batch. 

Resolution

Ir a Parametrización>Parámetros generales>Valores parámetros.

  • Seleccionar Capítulo TC Tronco común Grupo CUR Gestión de divisas, a nivel de Dossier.
  • Indicar la Divisa en el valor parámetro CURSHRFLD (Divisa en campos comunes).
  • Indicar el Tipo de cambio en el valor parámetro TYPCURSHR (Tipo de cambio en campos comunes).
    • Nota: si el Tipo de cambio fuese "Cambio día" es importante que tambien este creado en la función Cambio divisas, con el mismo Tipo de cambio
  • Registrar los Valores parámetros.
  • Salir de Sage X3, volver a entrar y, intentar nuevamente crear y validar la Campaña de reclamación.